Call not connecting?

Major incident Customer support
2026-08-26 13:36 BST · 2 days, 4 hours, 47 minutes

Updates

Resolved

The issue affecting audio quality and causing unexpected call disconnections has been fixed.

We appreciate your patience during this disruption and apologise for any inconvenience caused to your support experience.

August 28, 2026 · 18:19 BST
Issue

We are currently experiencing intermittent connectivity issues on our technical support lines, affecting audio quality and causing calls to disconnect unexpectedly.

If you are a UK customer in need of urgent technical support, please call our general support line at 0800 103 2959.

We apologise for the disruption and are working to fix the affected lines.

August 26, 2026 · 13:36 BST

← Back