Paymentsense app login issue

Major incident Paymentsense app and account
2025-10-22 12:48 BST · 1 hour, 9 minutes

Updates

Resolved

The issue with Paymentsense login has been resolved.

Thank you for your patience.

October 22, 2025 · 13:55 BST
Investigating

We are aware of an ongoing issue with customers being unable to login to the Paymentsense app and web portal.

We’re working on it urgently to get everything back up and running. We apologise for the inconvenience.

October 22, 2025 · 12:48 BST

← Back