Longer call wait time?

Major incident Customer support
2025-03-25 09:30 GMT · 1 day, 44 minutes

Updates

Resolved

This issue is now fixed.

Thank you for your patience.

March 26, 2025 · 10:13 GMT
Investigating

We are currently experiencing some technical difficulties with our phone lines which may cause a longer wait time.

If you need immediate assistance, please email us at ‘customer.service@paymentsense.com’.

We’re working on it urgently to get everything back up and running. Sorry for the inconvenience.

March 25, 2025 · 10:51 GMT

← Back