Some transfers are running late

Major incident Transfers
2025-03-24 18:11 GMT · 15 hours, 42 minutes

Updates

Resolved

Some settlement payments for Business Funding customers were delayed due to an issue with our third-party banking provider. This issue has now been resolved and all affected customers should have received their payments this morning.

We apologize for any inconvenience this may have caused. Thank you for your patience.

March 25, 2025 · 09:51 GMT
Investigating

Some customers with Business Funding are experiencing settlement delays due to technical issues with a third-party partner. We are working with the partner urgently to investigate and resolve the issues. We will share updates as and when we become aware of them on this status page.

March 24, 2025 · 18:11 GMT

← Back