Call not connecting?
Major incident
Customer support
2025-01-29 08:30 GMT
· 2 hours, 51 minutes
Updates
Monitoring
January 29, 2025 · 09:31 GMT
Calls are now connecting successfully.
Thank you for patience.
Issue
January 29, 2025 · 08:43 GMT
We are currently experiencing technical difficulties with our phone lines
If you need immediate assistance, please email us at ‘customer.service@paymentsense.com’.
We’re working on it urgently to get everything back up and running. Sorry for the inconvenience.
← Back