Some payments declining

Major incident Card machines
2025-01-26 18:29 GMT · 6 hours, 53 minutes

Updates

Resolved

All payments are now working again.

The issue has now been resolved and you can keep taking payments as normal. Thanks for your patience.

January 27, 2025 · 01:22 GMT
Issue

Sorry, transactions are down currently for some Paymentsense customers, but we’re working to fix it.

Some payments are getting declined at the moment. We’re working on it urgently to get everything back up and running. Thanks for your patience.

January 26, 2025 · 18:29 GMT

← Back