All payments are now working again.

Major incident Card machines Integrations Customer support Online Payments
2024-09-12 11:38 BST · 6 hours, 15 minutes

Updates

Resolved

Earlier today we experienced a technical issue caused by a third party, which prevented some Paymentsense customers from transacting. This issue has now been resolved and you can keep taking payments as normal. Thanks for your patience.

September 12, 2024 · 18:53 BST
Monitoring

Payments should now be working again.

Your machine should now be taking payments as normal.

September 12, 2024 · 17:46 BST
Investigating

We’re aware of an issue with a third party which is preventing some Paymentsense customers from transacting.
We’re continuing to working on it urgently to get everything back up and running. Sorry for the inconvenience.

September 12, 2024 · 12:52 BST
Investigating

We’re aware of an issue with a third party which is preventing some Paymentsense customers from transacting.
We’re continuing to working on it urgently to get everything back up and running. Sorry for the inconvenience.

September 12, 2024 · 12:38 BST
Investigating

We’re aware of an issue with a third party which is preventing some Paymentsense customers from transacting.
We’re working on it urgently to get everything back up and running. Sorry for the inconvenience.

September 12, 2024 · 10:58 BST

← Back